ghurlbut

log4net dependency causing conflict

0 votes
We are integrating e-SignLive with an EPiServer site. The EPiServer version we are using depends on log4net version 1.2.10 but the Silanis.ESL.dll depends on 1.2.13. We tried using a binding redirect in the application's web config with no luck. Is there a way to get the Silanis dll that works with log4net version 1.2.10? Our other alternative will be to upgrade the EPiServer version, which we did not anticipate for our project's scope.

Reply to: log4net dependency causing conflict

0 votes
Let me look into this and I will let you know what I find!

- Michael Partner and Developer Technologies Manager, OneSpan Facebook - Twitter - LinkedIn


Reply to: log4net dependency causing conflict

0 votes
Having the same issue here. Currently developing an older version of the Silanis DLL we got back in May that still uses log4Net 1.2.10. Hoping this is resolved so we can use the latest version.

Reply to: log4net dependency causing conflict

0 votes
So, you're also needing 1.2.10 and having issues with the eSignLive SDK depending on log4Net 1.2.13?

- Michael Partner and Developer Technologies Manager, OneSpan Facebook - Twitter - LinkedIn


Hello! Looks like you're enjoying the discussion, but haven't signed up for an account.

When you create an account, we remember exactly what you've read, so you always come right back where you left off