Last modified: 2022-10-28

Pour commencer avec les SDK

Les sections suivantes peuvent vous aider à démarrer avec les SDK de OneSpan Sign :

Communication SSL

L'intégration avec OneSpan Sign est sécurisée par un certificat SSL émis par GlobalSign. Ainsi, ce certificat intermédiaire GlobalSign doit être installé dans votre environnement d'intégration.

Bien que vous puissiez ajouter n'importe quel certificat dans la chaîne de certificats, le certificat Root-CA devrait convenir à la plupart des environnements.

Environnement d'intégration

À la lumière de la vulnérabilité de sécurité Logjam, OneSpan Sign a augmenté sa clé DH SSL de 1024 bits à 2048 bits.

Les anciennes versions de Java et de .NET ne pourront plus se connecter à OneSpan Sign, car elles ne prennent pas en charge la clé de cryptage plus grande.

Détails du certificat

Certificate serial#: 04 00 00 00 00 01 21 58 53 08 a2
Thumbprint: d6 9b 56 11 48 f0 1c 77 c5 45 78 c1 09 26 df 5b 85 69 76 ad

Lien de téléchargement : https://secure.globalsign.net/cacert/Root-R3.crt

OneSpan Sign Java SDKs

Nos SDK Java permettent l'intégration avec toute application écrite dans le langage de programmation Java.

Par défaut, les SDK .NET et Java ne sont pas sécurisés pour fils d'exécution. Si vous exécutez ce code dans une application en chapelet, vous pouvez rencontrer des conditions de course et des blocages. C'est pourquoi nous recommandons que chaque fil d'exécution dispose de sa propre instance du SDK.

Exigences minimales

Votre JVM doit utiliser Java 1.7.0_21 ou une version plus récente.

Pour identifier la version de Java installée sur votre système, exécutez la commande suivante :

java -version

Si vous voulez travailler avec un OneSpan Sign Java SDK téléchargez la version 11.

Pour afficher la documentation Javadoc d'un OneSpan Sign Java SDK, utilisez la procédure suivante :

  1. Naviguez vers notre répertoire MVN OneSpan Sign, qui se trouve ici :https://mvnrepository.com/artifact/com.silanis.esl/sdk

  2. Sélectionnez la version du SDK pour laquelle vous souhaitez obtenir de la documentation. Par exemple, 11.45.

  3. Dans la ligne Fichiers , cliquez sur Afficher tout.

  4. Téléchargez et décompressez le fichier suivant : sdk-<version number>-javadoc.jar

Les OneSpan Sign Java SDKs prennent en charge Java 1.7_21 et plus.

Pour obtenir plus d'informations, consultez les exemples GitHub ci-dessous.

Téléchargement de la dernière version du SDK 11

  • Pour télécharger le SDK OneSpan Sign.JAVA, cliquez ici. 

Pour afficher la documentation Javadoc pour une version du OneSpan Sign Java SDK, utilisez la procédure suivante :

  1. Naviguez vers notre répertoire MVN OneSpan Sign, qui se trouve ici :https://mvnrepository.com/artifact/com.silanis.esl/sdk

  2. Sélectionnez la version du SDK pour laquelle vous souhaitez obtenir de la documentation. Par exemple, 11.45.

  3. Dans la ligne Fichiers , cliquez sur Afficher tout.

  4. Téléchargez et décompressez le fichier suivant : sdk-<version number>-javadoc.jar

Installation

Pour savoir si ce certificat est déjà installé dans votre environnement, exécutez la commande suivante :

keytool -list -keystore <JAVA_HOME/lib/security/cacerts> | grep -i d6:9b:56:11:48:f0:1c:77:c5:45:78:c1:09:26:df:5b:85:69:76:ad

Si le certificat n'est pas installé, installez-le en exécutant la commande suivante :

keytool -importcert -alias GlobalSignRootCAR3 -keystore <JAVA_HOME/lib/security/cacerts> -file Root-R3.crt

Exemple de code Java

Utilisateurs de Maven

Si vous êtes un utilisateur de Maven, ajoutez à votre fichier pom l'une des dépendances suivantes.

Pour le SDK 11 :

<dependency>
            <groupId>com.silanis.esl</groupId>
            <artifactId>sdk</artifactId>
            <version>11.xx</version>
            <classifier>jar-with-dependencies</classifier>
        </dependency>

Si vous voulez la version du SDK qui regroupe toutes les dépendances, ajoutez <classifier>jar-with-dependencies</classifier> à la dépendance.

OneSpan Sign .NET SDKs

Nos SDK .NET permettent l'intégration avec toute application écrite dans le langage de programmation C#.

Si vous souhaitez travailler avec un OneSpan Sign .NET SDK, téléchargez la version 11 et effectuez la configuration supplémentaire décrite ci-dessous. Pour obtenir plus d'informations, consultez les exemples GitHub ci-dessous.

Par défaut, les SDK .NET et Java ne sont pas sécurisés pour fils d'exécution. Si vous exécutez ce code dans une application en chapelet, vous pouvez rencontrer des conditions de course et des blocages. C'est pourquoi nous recommandons que chaque fil d'exécution dispose de sa propre instance du SDK.

Exigences minimales

.NET

Nous prenons désormais en charge .NET Standard 2.0 et .NET framework 4.5 ou plus. Cela signifie que .NET Core est également pris en charge et que les machines Linux peuvent également être utilisées.

Pour identifier le framework .NET installé sur votre système, suivez les instructions de ce lien : https://msdn.microsoft.com/en-us/library/hh925568

SDK 11

  • Pour télécharger le SDK OneSpan Sign.NET, cliquez ici. 

Installation

Pour installer le certificat, double-cliquez sur le fichier Root-R3.crt et sélectionnez ensuite installer le certificat.

Exemples de codes .NET

OneSpan Sign Mobile SDKs

Nos SDK mobiles permettent l'intégration d'applications Web sur les téléphones mobiles et les tablettes.

Lequel s'applique à vous dépend de votre système d'exploitation :

  • Pour savoir comment télécharger et intégrer le SDK iOS, cliquez ici.
  • Pour savoir comment télécharger et intégrer le SDK Android, cliquez ici.

OneSpan Sign APEX SDK

Écrit en APEX, le OneSpan Sign APEX SDK for Salesforce permet aux développeurs d'intégrer la fonctionnalité de signature électronique dans leurs applications personnalisées sur Salesforce ou la plateforme Force.com.

X